ProChip BADASS eBIKES

Autor Thema: Akku stellt sich tot  (Gelesen 3686 mal)

Offline BitSchubser

  • Full Member
  • ***
  • Join Date: Jul 2013
  • Beiträge: 140
  • Dankeschön: 50 mal
Akku stellt sich tot
« am: 29. Juni 2015, 23:59 »
Eigentlich sah das das ganz gut aus mit dem Akku, den ich für kleines Geld vom Händler bekommen habe.
Der Akku hatte nur 44V und einen SOC von 20%, ließ sich aber nicht weiter laden. Die Batterie Info förderte einen Ausreißer bei den Zellspannungen zutage. Die Zellen 1-12 zeigten 3,4V und die Zelle 13 3,9V an. Ich habe den Akku dann zerlegt, um an die Anschlüsse zu kommen und habe nachgemessen: Alle Zellen hatten etwa 3,4V. Dann habe ich mit der Zellkalibrierung den Messwert auf 3,4V korrigiert und das Ladegerät wieder angeklemmt.
Diesmal konnte der Ladevorgang erfolgreich beendet werden, super!
Wo der Akku schon mal offen war hab ich noch die Steckerbelegung des 20 poligen Steckers ausgekundschaftet.

Heute den ganzen Kram wieder ins Gehäuse geferkelt und angesteckt: kein Bild, kein Ton beim Versuch des Einschaltens. Also wieder zerlegt und so angeschlossen, wie die Tage zuvor, nix.
Auch mit Ladegerät kein Leuchten der Buchse, kein piepsen, so rein gar keine Reaktion. Akkuspannung ist 52V, also volle Dröhnung.

Jemand ne Idee, oder hab ich das Teil kaputtrepariert?

Gruß
Thorsten
 

Offline magum

  • Newbie
  • *
  • Join Date: Apr 2014
  • Beiträge: 27
  • Dankeschön: 1 mal
Re: Akku stellt sich tot
« Antwort #1 am: 30. Juni 2015, 06:02 »
Falls es sich um Version 6.2 handelt und Du ein Multimeter besitzt: Messe bitte mal die Spannung am 2. Pin von oben an J200. Also diesen Löchlein links neben dem Controller. Da liegt normalerweise die 3,3 V Versorgungspannung und ich vermute mal die fehlt nun. GND ist z.B auf Pin 3. Auf der Rückseite am CAN Stecker findet man noch die 5 V und 12 V, wo hab ich nicht im Kopf.
« Letzte Änderung: 30. Juni 2015, 07:36 von magum »
 

Offline BitSchubser

  • Full Member
  • ***
  • Join Date: Jul 2013
  • Beiträge: 140
  • Dankeschön: 50 mal
Re: Akku stellt sich tot
« Antwort #2 am: 30. Juni 2015, 09:54 »
Stimmt, die 3,3V fehlen. Wie bekomme ich die wieder, dass der Professor wieder arbeiten kann?

Die 5V und 12V am CAN Anschluss sind auch nicht da. Die fehlen allerdings auch beim intakten Akku. Vermutlich werden die erst nach dem Einschalten geschaltet.

Am Wake Pin ist konsequenterweise auch nix, der hatte sonst 3,3V wohl über einen Pullup.

Zerknirscht
Thorsten
 

Offline magum

  • Newbie
  • *
  • Join Date: Apr 2014
  • Beiträge: 27
  • Dankeschön: 1 mal
Re: Akku stellt sich tot
« Antwort #3 am: 30. Juni 2015, 11:00 »
Gute Frage!  :)

Ich habe auch so eine Platine, aber die hat z.B. die 5 und 12 V, wenn das Netzteil angesteckt wird. Nur gerade nicht griffbereit. Falls niemand hier mehr darüber weiß, helfe ich Dir aber gern beim Erforschen, wo denn der Spannungsregler dafür sitzt. Interessiert mich ja selber. Entweder ist der defekt, bekommt selbst keine Spannung oder schaltet seinen Ausgang ab, weil die Schaltung dahinter zuviel Strom zieht.
 

Offline BitSchubser

  • Full Member
  • ***
  • Join Date: Jul 2013
  • Beiträge: 140
  • Dankeschön: 50 mal
Re: Akku stellt sich tot
« Antwort #4 am: 01. Juli 2015, 00:21 »
dankenswerterweise haben die die verbauten Chips alle übermalt. Beim Prozessor kann man noch grob das Motorola Logo erahnen, beim Rest nix mehr. Und bei der Packungsdichte ist da wohl eh nix zu machen.

Ich habe noch mal die Sicherung gezogen und wieder eingesteckt und auf ein Power-On-Reset gehofft. Beim Einstecken hat's etwas gefunkt, irgendwer zieht da also schon Strom.

Das ist vermutlich ein Exitus. Schade, so kurz vorm Ziel. Die ganze Zeit hat der Akku auch immer noch gepiepst, wenn ich die Platine angefasst und die Sensoranschlüsse erwischt habe. Die einzige Erklärung, die ich habe ist, dass ich da was beim ohmschen Messen der Temperatursensoren zerlegt habe. Weil der Stecker so klein ist, hab ich von unten an der Platine gemessen. Mag sein, dass die 9V des Messgeräts einen 3,3V Chip gehimmelt haben.
Allerdings erklärt das nicht die Abwesenheit der Betriebsspannung.

Muss ich wohl einen Plan B entwickeln. Die Zellen sind noch prima, der Akku ist 3 Jahre alt und 64 Ladezyklen hatte ich ausgelesen.

Gruß
Thorsten
 

Offline magum

  • Newbie
  • *
  • Join Date: Apr 2014
  • Beiträge: 27
  • Dankeschön: 1 mal
Re: Akku stellt sich tot
« Antwort #5 am: 01. Juli 2015, 09:26 »
Hallo Thorsten,

übermalt sind die nur zum Schutz, nicht um Bastler zu verärgern. Von Motorola ist gar keiner drauf, sondern von Microchip. Bislang hab ich sogar 2 gefunden. Einer hängt am CAN-Bus und der andere controll(i)ert wahrscheinlich per PWM die Ladeschaltung, bzw. den DCDC-Wandler.

Da ich dank Dir ja öfter etwas schneller zu hause war, habe ich mal gesucht und auch einen Spannungsregler gefunden, wo 3,3 V raus kommen. Der ist auf der Rückseite unter dem Lader-Stecker und hat die Bezeichnung U1. Von den drei unteren Anschlüssen, hat der rechte (zum Rand gelegene) ca. 5,5 V und der  linke (innere) die 3.3 V. Die anderen beiden sind GND. Allerdings scheint  dieser Regler laut Piepser nur mit der Ladeschaltung verbunden zu sein. Jedenfalls nicht mit dem Pin den ich Dir gestern genannt hab.  Trotzdem kannst Du ja vielleicht mal prüfen, was da bei Dir anliegt. Bei meinem Patienten fehlt schonmal die Spannung am Eingang. 

Ich habe von Niko und Mastergraf aus diesem Forum gesperrte oder defekte Platinen für solche Forschungen erhalten, würde mich freuen Gleichgesinnte zu finden, sich über die Funktion der Schaltung auszutauschen. Allein tut man sich da immer schwerer. Das Ziel ist BionX Nutzern helfen und auch Leuten wie Dir etwas zurückgeben zu können, solange es nur sehr schwer Ersatz für diese Schaltungen gibt. Hilfreich für solche Analysen wäre vielleicht, mal die Funktion der Test-Pins zu entschlüsseln.

Mein Plan B wäre eine Schaltung die auf dem CAN Bus zumindest grundlegend so tut, als wäre sie ein BionX BMS. Dazu hab ich mir mal das SmartBMS aus China bestellt. Aber sinnvoller wäre es schon, das vorhandenes Material recyceln zu können.

Gruß
 Magum
 

Offline BitSchubser

  • Full Member
  • ***
  • Join Date: Jul 2013
  • Beiträge: 140
  • Dankeschön: 50 mal
Re: Akku stellt sich tot
« Antwort #6 am: 01. Juli 2015, 23:45 »
Hallo Magum,

vielen Dank für Deine Unterstützung. An den genannten Pins liegt hier auch nichts an.

Eine Schutzschicht hatte ich auch vermutet, die ganze Platine sieht aus, als wäre sie mit Platikspray überzogen worden. Macht ja Sinn gegen Schmutz und Feuchtigkeit. Aber der Umstand, dass das auf der Platine transparent ist und die Widerstände lesbar sind kässt mich vermuten, dass die Transen und Controler willentlich unleserlich gemacht wurden.

In diese Platine will ich aber nicht zu tief einsteigen. Selbst, wenn man das defekte Bauteil ausmachen könnte, wäre es mit Bordmitteln nicht zu ersetzen. Himmel das Ding ist so dicht gepackt und die Teile so klein, da reicht ja meine Lötbrille plus Lupe kaum aus. Hätte mein Rasterelektronenmikroskop nicht weggeben sollen.

Hälst Du den J8 auch für einen unbestückten Programmieranschluss? Einige Pins gehen an Widerstände, einer direkt zum Prozessor, einer auf Gnd. Andere verschwinden in einem Loch, das auf der anderen Seite nicht weitergeht. Das nährt den Verdacht, dass die Platine mehr als zweilagig ist. Ich frage mich, ob man den Prozessor nicht fremdversogen kann, um zu sehen, ob er noch sinnvolles tut.

Da scheint mir mein Plan B, der ziemlich dem Deinen entspricht aussichtsreicher. Arduino und CAN Adapter sind bestellt. Der Charme der Lösung ist, dass man auch ganz eigene Akkus bauen könnte. Im ersten Wurf würde ich sagen, dass es genügt der Konsole Plausible Antworten zu liefern, dass sie denkt "prima Akku". Im Folgenden kann man dann man schauen, wie man Ladezustand, Strom, Uhrzeit etc. ermittelt und korrekte Werte zurückliefert.
Der nächste Winter kommt bestimmt, mal schauen, wo die Reise hingeht.

SmartBMS habe ich gefunden, nach sowas hab ich auch schon gesucht. Welchen hast Du genommen?

Gruß
Thorsten
« Letzte Änderung: 02. Juli 2015, 01:19 von BitSchubser »
 

Offline magum

  • Newbie
  • *
  • Join Date: Apr 2014
  • Beiträge: 27
  • Dankeschön: 1 mal
Re: Akku stellt sich tot
« Antwort #7 am: 02. Juli 2015, 16:13 »
Ich habe mir dieses bestellt, ist aber noch unterwegs

You are not allowed to view links. Register or Login

Da findet man einiges (nicht nur gutes, China-Qualität halt) im Internet drüber. Das Interessante für Bit- und Elektronen-Schubser ist wohl die Kommunikation mit dem OZ890 Chip Über I2C. Man kann halt auch hier vieles einstellen, die Spannungen der Zellen beobachten, usw. Ein Beispiel für die Kommunikation mit AVR-Controller findet man im Pedelecforum.

Auf dem BionX BMS findet man die Bezeichnungen der Bauteile noch unter der Lackschicht.

Da ich mit defekten Platinen spiele, hängen die nicht mehr am Akku,  sondern nur am Ladekabel. Da scheint dann die kleine Spule L101 (oben links in der Ecke) Teil eines Schaltreglers zu sein, der aus den 26 V (getaktet, unterer Pin) 12 V (oben) macht. Aus dieser werden scheinbar die 5 V (Elko C106) erzeugt und daraus wiederum die 3.3 (C212). Jedenfalls sind meine 5 V hier sind nur knapp 4. Drum hab ich statt 3,3 V nur 1,3 V Versorgungsspannung und das BMS macht keinen Pieps mehr. Der 12 V Regler ist Q101. Wenn bei Dir schon die 12 V fehlen, würde ich  mal die Bauteile in der linken oberen Ecke untersuchen. Die sieht man auch noch ohne Lupe. ;-) Viel zu verlieren hast Du ja auch nicht mehr, wenn Du mal mit einem Labornetzteil, ganz vorsichtige, strombegrenzte Versorgungsspannung anlegst.

Wofür J8 ist, keinen Schimmer. Programmieren sollte man den PIC U200 über J200  und U303 über J301 können. Das ist meine nächste Baustelle, um eventuell gesperrte BMS downgraden oder gar debuggen zu können, was mit dem BIB ja scheinbar nicht mehr funktioniert. 
 

Offline ulf_l

  • Newbie
  • *
  • Join Date: Nov 2014
  • Beiträge: 41
  • Dankeschön: 2 mal
Re: Akku stellt sich tot
« Antwort #8 am: 16. Juli 2015, 13:14 »
You are not allowed to view links. Register or Login
[...]Im ersten Wurf würde ich sagen, dass es genügt der Konsole Plausible Antworten zu liefern, dass sie denkt "prima Akku". Im Folgenden kann man dann man schauen, wie man Ladezustand, Strom, Uhrzeit etc. ermittelt und korrekte Werte zurückliefert.
Der nächste Winter kommt bestimmt, mal schauen, wo die Reise hingeht.
[...]

Hallo

In die Richtung hab ich auch schon überlegt. Die Rekuperation käme dann noch dazu. Bei mir würde es aber auch frühestens im Winter konkret werden.

Gruß Ulf
 

Offline Ebiker0815

  • Newbie
  • *
  • Join Date: Jun 2015
  • Beiträge: 13
  • Dankeschön: 1 mal
Re: Akku stellt sich tot
« Antwort #9 am: 17. August 2015, 12:25 »
Hallo,
wollte mal fragen wie weit es mit der Idee eines eigenen Akkus gediehen ist.

Hatte meinen Akku zum Einbau neuer Zellen eingesendet,
dabei ist er leider "defekt" gegangen.
Neue "gebrachte" Platinen habens nicht gebracht,
da das BMS nicht mitmacht.
Mit dem Anbieter habe ich zwar eine Einigung erzielt,
Jedoch wird das Problem mit dem BionX BMS wieder offen gelegt O_o.

Mein Traum wäre ein eigenes BMS z.B. Smart BMS und ein "Platinchen" welches mit dem Bionx-System kommuniziert...

Kann E-technisch gerne meinen Beitrag leisten,
aber SW müsste definitiv von anderer Seite kommen.

Habt Ihr schon Ansätze?
Oder ist das Thema vom Tisch?

Würde mich echt freuen,
wenn wir da was auf die Beine stellen könnten.

Gruß an alle fleißigen Helfer.
 

Offline BitSchubser

  • Full Member
  • ***
  • Join Date: Jul 2013
  • Beiträge: 140
  • Dankeschön: 50 mal
Re: Akku stellt sich tot
« Antwort #10 am: 17. August 2015, 22:14 »
Das Thema ist keineswegs vom Tisch. Da ich meine Platine irgendwie gehimmelt habe und meine Geduld da drauf rumzusuchen eingeschränkt ist, habe ich nun ein fast neues Akkupaket ohne Elektronik. Ein Eigenbau scheint mir die einfachere Lösung zu sein, als auf der BionX Platine den Fehler zu suchen.

Ich schlage aber vor, dafür einen eigenen Thread zu eröffnen.

You are not allowed to view links. Register or Login


Thorsten
 

 

UA-12726453-11 Sponsoren: Open eBike SHOP | ProChip | BADASS eBIKES